composer

codeception/codeception
codeception/lib-asserts
codeception/module-asserts
codeception/module-filesystem
codeception/module-webdriver

composer-runtime-api

derhansen/pwd_security_check

friendsofphp/php-cs-fixer
friendsoftypo3/phpstan-typo3

composer/package-versions-deprecated
icanhazstring/composer-unused
Insolita/unused-scanner

kalessil/production-dependencies-guard:dev-master

oliverklee/phpunit
phan/phan
phpmd/phpmd
phpspec/prophecy
phpstan/phpstan
phpunit/php-code-coverage
phpunit/phpunit
rector/rector
squizlabs/php_codesniffer
typo3/testing-framework
vimeo/psalm

michielroos/typo3scan
mikey179/vfsstream
nesbot/carbon
php-webdriver/webdriver
phpcompatibility/php-compatibility
phpoffice/phpspreadsheet
phpoffice/phpword

sensiolabs/security-checker

spatie/pdf-to-text
typo3/cms-styleguide

typo3-dev tools

“require-dev”: {
“kalessil/production-dependencies-guard”: “dev-master”,
“stefanfroemken/mysqlreport”: “dev-master”,
“bnf/phpstan-psr-container”: “^1.0”,
“codeception/codeception”: “^4.1 || ^5.0.0”,
“codeception/module-asserts”: “^1.3”,
“codeception/module-cli”: “^1.1 || ^2.0.0”,
“composer-runtime-api”: “^2.2”,
“friendsoftypo3/phpstan-typo3”: “^0.9.0”,
“icanhazstring/composer-unused”: “*”,
“insolita/unused-scanner”: “^2.4”,
“localizationteam/l10nmgr”: “^10.2”,
“michielroos/typo3scan”: “^1.7”,
“phpstan/phpstan”: “^1.5”,
“phpstan/phpstan-phpunit”: “^1.0”,
“phpunit/php-code-coverage”: “*”,
“phpunit/phpunit”: “^9.5”,
“rector/rector”: “^0.12.19”,
“roave/security-advisories”: “dev-latest”,
“symfony/filesystem”: “^5.4”,
“typo3/coding-standards”: “^0.5.0”,
“typo3/testing-framework”: “^6.16”,
“oliverklee/oelib”: “^5.0”,
“vimeo/psalm”: “^4.22”
}